Rowan System Status
Subscribe To Updates

Power outage causing network disruptions on Glassboro campus

Incident Report for Rowan University

Resolved

This incident has been resolved.
Posted May 18, 2026 - 18:18 EDT

Investigating

A power outage across much of the Glassboro campus is affecting access to wireless and wired internet and other network services in several buildings.

Rowan University's data centers are supported with backup generators, and we expect them to remain online despite the power outage.

Network services remain online in Camden and Stratford. We do not expect interruptions on those campuses due to this issue.
Posted May 18, 2026 - 09:39 EDT
This incident affected: Network & WiFi (WiFi (RowanSecure, RowanWiFi & Eduroam), Wired Network Access).