Rowan System Status
Subscribe To Updates

Banner posting process is down

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue with Banner posting. All pending transactions have been successfully posted.
Posted Mar 25, 2025 - 09:56 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 25, 2025 - 09:48 EDT

Identified

Information Resources & Technology is aware of an issue with the Banner posting process. Currently journal entries are not posting.

Technicians are actively working on this issue. Updates will be provided as they are available.
Posted Mar 25, 2025 - 09:47 EDT
This incident affected: Banner (Banner Administrative Pages (banner9.rowan.edu/applicationNavigator/seamless)).