Rowan System Status
Subscribe To Updates

Delay in emails being received

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue the caused a delay in receiving inbound emails.

The backlog of inbound emails has been cleared and email flow has returned to normal.
Posted Mar 31, 2025 - 18:34 EDT

Identified

Information Resources & Technology is actively investigating the issue that caused a delay in receiving inbound emails.

Inbound emails are now being received.

Another update will be provided as soon as the backlog of inbound emails has been cleared.
Posted Mar 31, 2025 - 18:09 EDT

Investigating

Information Resources & Technology is aware of an issue that is causing a delay in emails being received. This issue affects emails sent from outside of Rowan University, i.e. from Banner, ServiceNow, etc. Technicians are aware of this issue and are actively working to resolve this as quickly as possible.

Updates will be provided as they are available.
Posted Mar 31, 2025 - 13:34 EDT
This incident affected: Microsoft 365 (Exchange Email (outlook.office.com)).